php版本相关函数


最近在调试php程序的时候,在服务器上php的版本与本地的版本不一致,我有个变量使用了低版本不支持的数值,导致部署到服务器运行出错,调试了半天,查看文档,发现那个参数值只能在5.4以后可用。为了在本地调试的时候可看,在服务器上又可以运行,加上了判断php版本的处理。以前没有对这块做深入的了解,今天看了看文档,做个记录以后再用。
PHP_VERSION(string) 其值形如:5.4.0
version_compare — 对比两个「PHP 规范化」的版本数字字符串

if(version_compare ( PHP_VERSION ,  '5.4.0' ) >=  0 ){
     //just do it
}
普人特福的博客cnzz&51la for wordpress,cnzz for wordpress,51la for wordpress